Just to let everyone know who isn't using Firefox, the newest version of that browser has been updated to warn if you are logging in to a website that could allow p***************words to be compromised.

Here is the link to the warning I get when logging in to flightinfo...

https://support.mozilla.org/t5/Prote...fox/ta-p/27861